Bullet Damage

Плъгини използващи ReAPI модула.
Аватар
iv69
Извън линия
Потребител
Потребител
Мнения: 719
Регистриран на: 17 Мар 2018, 15:34
Се отблагодари: 209 пъти
Получена благодарност: 32 пъти

Bullet Damage

Мнение от iv69 » 12 Яну 2020, 20:32

OciXCrom написа:
27 Май 2017, 21:04
Няма почти никаква разлика какво ще ползваш. Не малко работа има да се направи подобно нещо.
Аз мисля, че точно такъв плъгин, какъвто Лошия търси - вече го има изработен !? Намерих за ReHLDS/ReAPI ето това Damager 0.0.6 оттук:
https://goldsrc.ru/threads/4363/

Ако иска, може някой от тук да качи плъгина официално със превода, аз там нямам регистрация и не мога да "свалям"?!

Аватар
Gmilanov
Извън линия
Рекламатор
Рекламатор
Мнения: 127
Регистриран на: 13 Апр 2019, 14:32
Се отблагодари: 7 пъти
Получена благодарност: 7 пъти
Обратна връзка:

Bullet Damage

Мнение от Gmilanov » 17 Фев 2021, 12:00

Здравейте, при опит за локално компилиране ми излиза Warning , и след това плъгина не работи .

При отпит за компилиране:

Код за потвърждение: Избери целия код

//// reapi_bullet_damage.sma
// C:\Users\gmila\Desktop\addons\amxmodx\scripting\include\reapi_gamedll_const.inc(803) : warning 200: symbol "RG_CBasePlayerWeapon_DefaultDep" is truncated to 31 characters
// C:\Users\gmila\Desktop\addons\amxmodx\scripting\include\reapi_gamedll_const.inc(810) : warning 200: symbol "RG_CBasePlayerWeapon_DefaultRel" is truncated to 31 characters
// C:\Users\gmila\Desktop\addons\amxmodx\scripting\include\reapi_gamedll_const.inc(817) : warning 200: symbol "RG_CBasePlayerWeapon_DefaultSho" is truncated to 31 characters
// Header size:            452 bytes
// Code size:             1332 bytes
// Data size:              756 bytes
// Stack/heap size:      16384 bytes; estimated max. usage=528 cells (2112 bytes)
// Total requirements:   18924 bytes
//
// 3 Warnings.
// Done.
//
// Compilation Time: 0,41 sec
// ----------------------------------------

Press enter to exit ...

В конзолата на съвръра.

Код за потвърждение: Избери целия код

unknown            unknown     unknown           reapi_bullet_damage.amxx        error 



Лога с грешки:

Код за потвърждение: Избери целия код

L 02/17/2021 - 11:11:49: [AMXX] Plugin ("reapi_bullet_damage.amxx") is setting itself as failed.
L 02/17/2021 - 11:11:49: [AMXX] Plugin says: [ReAPI]: Api minor version mismatch; expected at least 19, real 12
L 02/17/2021 - 11:11:49: [AMXX] Run time error 1 (plugin "reapi_bullet_damage.amxx") - forced exit

Аватар
impossible
Извън линия
Потребител
Потребител
Мнения: 355
Регистриран на: 15 Юни 2019, 12:41
Се отблагодари: 23 пъти
Получена благодарност: 20 пъти
Обратна връзка:

Bullet Damage

Мнение от impossible » 17 Фев 2021, 12:16

Reapi версията която ползваш на сървара не е съвместима с тази която си компилирал и нямаш всички нужни Reapi библиотеки

Аватар
Gmilanov
Извън линия
Рекламатор
Рекламатор
Мнения: 127
Регистриран на: 13 Апр 2019, 14:32
Се отблагодари: 7 пъти
Получена благодарност: 7 пъти
Обратна връзка:

Bullet Damage

Мнение от Gmilanov » 17 Фев 2021, 12:22

Добре , а може ли тогава същия плъгин без reapi , благодаря.

Аватар
Just
Извън линия
Потребител
Потребител
Мнения: 365
Регистриран на: 23 Дек 2016, 19:10
Местоположение: http://cs-ultragaming.info
Се отблагодари: 5 пъти
Получена благодарност: 19 пъти
Обратна връзка:

Bullet Damage

Мнение от Just » 17 Фев 2021, 13:12

scripting.rar
(1.85 KiB) Свалено 11 пъти
scripting.rar
(1.85 KiB) Свалено 11 пъти
Изображение

Connect 93.123.18.6:27017
Connect 93.123.18.6:27015

Изображение

Аватар
Gmilanov
Извън линия
Рекламатор
Рекламатор
Мнения: 127
Регистриран на: 13 Апр 2019, 14:32
Се отблагодари: 7 пъти
Получена благодарност: 7 пъти
Обратна връзка:

Bullet Damage

Мнение от Gmilanov » 18 Фев 2021, 01:23

Това което си ми дал даже не е на същия автор , на мен ми трябва Bullte damage със флаг за имунитет или резервиран слот , само той да може да го вижда и да не е за Reapi.

Благодаря все пак, и се надявам някой да предложи плъгина който искам .

Аватар
impossible
Извън линия
Потребител
Потребител
Мнения: 355
Регистриран на: 15 Юни 2019, 12:41
Се отблагодари: 23 пъти
Получена благодарност: 20 пъти
Обратна връзка:

Bullet Damage

Мнение от impossible » 18 Фев 2021, 12:00

Напиши в конзолата AMXX version виж с каква версия на AmxmodX си след това си свали същата платформа за компилиране и замени include файловете на компилатора с тези на сървърната платформа.

И след това пробвай пак с този плъгин!

Публикувай отговор
  • Подобни теми
    Отговори
    Преглеждания
     Последно мнение

Обратно към “Плъгини за ReAPI”

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 2 госта