Как да ъпдейтнем сървъра до AMXX 1.10

Въпроси и проблеми свързани с AMXModX.
Аватар
OciXCrom
Извън линия
Администратор
Администратор
Мнения: 6393
Регистриран на: 06 Окт 2016, 19:20
Местоположение: /resetscore
Се отблагодари: 112 пъти
Получена благодарност: 849 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.10

Мнение от OciXCrom » 04 Сеп 2018, 17:03

Тъй като новите AMXX 1.9 и АМХХ 1.10 версии вече са достъпна за теглене като dev build, реших да направя тази тема за всеки да разбере как да ъпдейтне сървър от версия 1.8.2 или 1.8.3 до 1.10.0. Имайте предвид, че 1.9 все още не е официално пусната и все още ще се правят промени, обаче в момента е доста по-стабилна от предишните версиите, включително и от 1.8.2 и препоръчвам всеки да си я изтегли.

Ето и как става ъпдейтването:


  • Напълно спирате сървъра, тъй като някои от файловете може да не се обновят ако е включен.
  • Влизате в тази страница.
  • Зависимо от операционната система на която се намира сървърът ви, избирате Windows, Linux или Mac. Имайте предвид, че ако ползвате хостинг компания (99% от случаите), трябва да изберете операционната система която ползва хостът (почти винаги ще е Linux), а не тази на вашия компютър! Ако искате да изтеглите тестов сървър на вашия компютър или да ъпдетйнете вече съществуващ такъв, тогава избирате операционната система която ползва компютърът ви.
  • Цъкате на голямата икона с логото на операционната система и теглите два архива от списъка:
    • Base Package - това е базовият пакет който е нужен за всяка една игра
    • Counter-Strike - това е пакетът с добавки за Counter-Strike (естествено, ако ползвате друга игра, примерно Day of Defeat, теглите пакета за нея вместо този)
Изображение

  • Отваряте изтеглените файлове, влизате в addons/amxmodx и замествате следните файлове от двата архива:
  • Файлът core.ini в папката configs.
  • Всички файлове в папката data.
  • Всички файлове в папката dlls.
  • Всички файлове в папката modules.
  • В папката scripting можете да заместите всички файлове ако не сте правили промени по базовите плъгини. Ако сте правили промени по тях и не искате да ги загубите, няма нужда да замествате .sma файловете, обаче задължително трябва да заместите тези файлове:
    • Всички файлове в папката scripting/include.
    • Файлът amxxpc.exe (Windows) / amxxpc (Linux).
    • Файлът amxxpc32.dll (Windows) / amxxpc32.so (Linux).
    • Файлът compile.exe (Windows) / compile.sh (Linux).
  • Компилираните плъгини в папката plugins няма нужда да ги замествате ако искате да запазите старите плъгини или искате сами да ги компилирате.
  • Стартирате сървъра.

Аватар
smurfavr
Извън линия
Рекламатор
Рекламатор
Мнения: 426
Регистриран на: 06 Окт 2016, 17:55
Се отблагодари: 25 пъти
Получена благодарност: 16 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от smurfavr » 04 Сеп 2018, 18:13

Никъде не видях за хл?

Аватар
OciXCrom
Извън линия
Администратор
Администратор
Мнения: 6393
Регистриран на: 06 Окт 2016, 19:20
Местоположение: /resetscore
Се отблагодари: 112 пъти
Получена благодарност: 849 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от OciXCrom » 05 Сеп 2018, 00:34

smurfavr написа:
04 Сеп 2018, 18:13
Никъде не видях за хл?
Мм да, моя грешка. За HL няма отделен пакет, само базовият е нужен. Също така изпуснах една важна стъпка:
Файловете core.ini и hamdata.ini в папката configs
Благодаря на delirium, че ми напомни. Ще обновя клипа по-късно.

Аватар
Shapeshifter
Извън линия
Потребител
Потребител
Мнения: 49
Регистриран на: 10 Май 2018, 13:16
Се отблагодари: 1 път
Получена благодарност: 5 пъти

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от Shapeshifter » 05 Сеп 2018, 01:49

Плъгини вече компилирани под AMXX 1.8.3 ще работят ли на тази версия без прекомпилиране?
QuadGS.COM # ZombieApocalypse[Nanosuit|FreeVIP|SaveAP] # ZombieApocalypse[Nanosuit|SaveAP] - IP: 93.123.18.44:27015

Аватар
antonstoqnovv
Извън линия
Потребител
Потребител
Мнения: 163
Регистриран на: 15 Окт 2017, 10:40
Получена благодарност: 2 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от antonstoqnovv » 05 Сеп 2018, 02:42

Да,вчера го четох някъде

Аватар
OciXCrom
Извън линия
Администратор
Администратор
Мнения: 6393
Регистриран на: 06 Окт 2016, 19:20
Местоположение: /resetscore
Се отблагодари: 112 пъти
Получена благодарност: 849 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от OciXCrom » 05 Сеп 2018, 04:14

Shapeshifter написа:
05 Сеп 2018, 01:49
Плъгини вече компилирани под AMXX 1.8.3 ще работят ли на тази версия без прекомпилиране?
Да, няма нужда да се прекомпилират.

Аватар
smurfavr
Извън линия
Рекламатор
Рекламатор
Мнения: 426
Регистриран на: 06 Окт 2016, 17:55
Се отблагодари: 25 пъти
Получена благодарност: 16 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от smurfavr » 07 Сеп 2018, 17:51

Нещо са спрели изтеглянето за win.Само за Linux и Mac могат да се теглят файловете.

Аватар
OciXCrom
Извън линия
Администратор
Администратор
Мнения: 6393
Регистриран на: 06 Окт 2016, 19:20
Местоположение: /resetscore
Се отблагодари: 112 пъти
Получена благодарност: 849 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от OciXCrom » 07 Сеп 2018, 18:00

smurfavr написа:
07 Сеп 2018, 17:51
Нещо са спрели изтеглянето за win.Само за Linux и Mac могат да се теглят файловете.
Най-новият build за Windows все още не се е генерирал, понеже бе добавен преди няколко часа. Можеш да изгеглиш предишния (5209) по-долу в страницата. Не знам дали е нормално да има такова забавяне, ще им пиша ако не се оправи до после.

Аватар
antonstoqnovv
Извън линия
Потребител
Потребител
Мнения: 163
Регистриран на: 15 Окт 2017, 10:40
Получена благодарност: 2 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от antonstoqnovv » 07 Сеп 2018, 20:54

Защо ми дава няколко подобни грешки .. при положение че всички модули са си там и са си включени

Plugin "restmenu.amxx" failed to load: Module/Library "cstrike" required for plugin. Check modules.ini.

Аватар
OciXCrom
Извън линия
Администратор
Администратор
Мнения: 6393
Регистриран на: 06 Окт 2016, 19:20
Местоположение: /resetscore
Се отблагодари: 112 пъти
Получена благодарност: 849 пъти
Обратна връзка:

Как да ъпдейтнем сървъра до AMXX 1.9

Мнение от OciXCrom » 07 Сеп 2018, 21:06

Добавил ли си Counter-Strike пакета? Според грешката не си.

Публикувай отговор
  • Подобни теми
    Отговори
    Преглеждания
     Последно мнение

Обратно към “Поддръжка / Помощ”

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 2 госта