Error in `./hlds_linux': corrupted double-linked list: 0x11bcf740 *** Aborted

В този раздел можете да задавате всякакви въпроси свързани със самата игра или сървъри за нея в случай, че въпросът ви не се отнася за AMXX.
Правила на форума
ВАЖНО

В този раздел се пускат теми само и единствено свързани с играта или сървъри за нея в случай, че темата не се отнася за AMXX. Ако темата ви е свързана с AMXX или плъгини за AMXX, пуснете я в този раздел.
Аватар
hellmoss
Извън линия
AMXX Скриптър
AMXX Скриптър
Мнения: 68
Регистриран на: 15 Окт 2016, 20:24
Се отблагодари: 6 пъти
Получена благодарност: 9 пъти
Обратна връзка:

Error in `./hlds_linux': corrupted double-linked list: 0x11bcf740 *** Aborted

Мнение от hellmoss » 21 Окт 2020, 16:19

Здравейте, имам краш, никаква явна причина. Не съм спирал плъгините 1 по 1, дори подозирам, че е от както ъпдейтнах REHLDS последно. Някой имал ли е подобно?

AMX Mod X 1.10.0.5401

ReHLDS version: 3.7.0.698-dev
Build date: 10:14:22 Aug 19 2020 (2321)

Metamod-r v1.3.0.128, API (5:13)
Metamod-r build: 17:47:54 Aug 24 2018

Код за потвърждение: Избери целия код

*** Error in `./hlds_linux': corrupted double-linked list: 0x11bcf740 ***
Aborted

Аватар
atmax
Извън линия
Потребител
Потребител
Мнения: 444
Регистриран на: 22 Мар 2018, 15:06
Се отблагодари: 26 пъти
Получена благодарност: 34 пъти

Error in `./hlds_linux': corrupted double-linked list: 0x11bcf740 *** Aborted

Мнение от atmax » 22 Окт 2020, 21:56

Увери се че ползваш последната версия на metamod и най-вероятно проблема идва от някой плъгин, ето какво открих при един руснак:
Ошибка найдена, fakemeta и engine как обычно глючат.
pev_valid и is_valid_ent заменил на is_entity теперь всё шикарно.
Дело в том, что pev_valid считает удаленные объекты существующими.
И с гугъл преводач да си го преведеш, пак ще схванеш какво има предвид.
Провери си добре плъгините! И да може да се наложи да ги спираш 1 по 1.
Rest in peace my friend I always will remember you! 🖤👊

Аватар
hellmoss
Извън линия
AMXX Скриптър
AMXX Скриптър
Мнения: 68
Регистриран на: 15 Окт 2016, 20:24
Се отблагодари: 6 пъти
Получена благодарност: 9 пъти
Обратна връзка:

Error in `./hlds_linux': corrupted double-linked list: 0x11bcf740 *** Aborted

Мнение от hellmoss » 23 Окт 2020, 06:45

atmax написа:
22 Окт 2020, 21:56
Увери се че ползваш последната версия на metamod и най-вероятно проблема идва от някой плъгин, ето какво открих при един руснак:
Ошибка найдена, fakemeta и engine как обычно глючат.
pev_valid и is_valid_ent заменил на is_entity теперь всё шикарно.
Дело в том, что pev_valid считает удаленные объекты существующими.
И с гугъл преводач да си го преведеш, пак ще схванеш какво има предвид.
Провери си добре плъгините! И да може да се наложи да ги спираш 1 по 1.
В библиотеката ns2amx.inc откривам

Код за потвърждение: Избери целия код

stock is_entity(id)
	return is_valid_ent(id);
ерго няма много логика в поста му..?

Или той сигурно ползва reapi вариянта на is_entity, гледайки от мета листа му..

Може би има някаква логика, дори и при ъпдейтнат амхх, едва ли са пренаписвали core методите за валидност на ент, уж реапи върви с рехлдс и рехлдс може да създава някаква несъвместимост или пък проверките да са спрямо метамод-п, а не метамод-р; остава ми да пренаписвам 50 плъгина и да ползвам реапи навсякъде..

От години нямам крашове, по-скоро това би била опцията от колкото да спирам 1 по 1, мисля че знам какво правя и съм доста внимателен с ентитита, не успявам по никакъв начин да предизвикам краша каквото и да правя с ентитита за които се сещам че третирам в геймплея...

Публикувай отговор
  • Подобни теми
    Отговори
    Преглеждания
     Последно мнение

Обратно към “Помощ и въпроси / Поддръжка”

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 5 госта